El parche contra Meltdown bloquea algunas instalaciones de Ubuntu 16.04 con Linux 4.4

0
107
Want create site? Find Free WordPress Themes and plugins.

Meltdown en Ubuntu

El parcheo de Meltdown está dando más complicaciones de las que les gustaría a los desarrolladores de sistemas operativos. Si hace dos días nuestros compañeros de MuyComputer se hacían eco de que los parches de Microsoft habían bloqueado el inicio de Windows en algunas CPU AMD Athlon, algunas instalaciones de Ubuntu 16.04 con Linux 4.4 parece que tampoco se han librado de acabar de la misma manera, aunque sobre CPU Intel (aparentemente no se ha detectado la incidencia sobre AMD).

Según un fallo reportado en Lauchpad que fue confirmado y catalogado como de importancia crítica, algunos usuarios vieron que Ubuntu 16.04 no era capaz de iniciarse tras la instalación del kernel Linux 4.4.0-108-generic, que incluye el parche contra Meltdown. Por suerte, se podía acceder a Grub e iniciar el kernel 4.4.0-104-generic, que seguía siendo funcional.

Tras confirmarse el fallo, los desarrolladores de Ubuntu se pusieron manos a la obra para corregir el error que impedía el inicio de Ubuntu 16.04 con la versión de Linux 4.4 preparada contra Meltdown, hallando la solución rápidamente. Afortunadamente, parece que en Linux 4.4.0-109 ya se ha corregido el fallo y las instalaciones de Ubuntu 16.04 con Linux 4.4 tendrían que poder iniciarse sin complicaciones y con el parche contra Meltdown aplicado.

¿Tu instalación de Ubuntu 16.04 con Linux 4.4 no se inicia tras actualizar? Sigue estos pasos para arreglarlo:

  1. En Grub hay que seleccionar un kernel capaz de iniciarse correctamente. Si se tiene Ubuntu como único sistema, hay que presionar repetidamente la tecla escape nada más pasar la pantalla de inicio de la placa madre.
  2. Iniciar sesión.
  3. Realizar una actualización normal del sistema operativo, asegurándose de que se instalará el kernel Linux 4.4.0-109 o superior.
  4. Tras instalar las actualizaciones, reiniciar el sistema de la forma habitual.

Desarrollar un sistema operativo es algo complejo y a veces se cuelan regresiones y fallos. De hecho, no es la primera vez que Canonical se enfrenta a algo así, aunque en aquella ocasión el problema fue menos grave. La desarrolladora de Ubuntu ha reaccionado rápidamente en ambos casos, ofreciendo una solución en tan solo un día. Fallos como estos invitan a no utilizar el comando autoremove con mucha alegría, ya que versiones sin utilizar del kernel podrían salvar al usuario de tener que reinstalar el sistema ante incidencias de este tipo.


Source: muylinux

El parche contra Meltdown bloquea algunas instalaciones de Ubuntu 16.04 con Linux 4.4
Valora este post
Did you find apk for android? You can find new Free Android Games and apps.
Compartelo!!Share on Facebook1Share on Google+0Tweet about this on TwitterShare on LinkedIn0